Skip to main content

Reply to this post | Go Back
View Post [edit]

Poster: Soft Phase netlabel Date: Nov 20, 2009 12:08pm
Forum: faqs Subject: Corrupt zip file with "download whole directory"

It seems that downloading the entire directory with these items results in a zip file that is corrupt and cannot be completely extracted:

http://www.archive.org/details/sfp01
http://www.archive.org/details/sfp01flac

Downloading the invidual files from the items seem to be ok.

The odd thing is, that they are not even on same server
(ia310813 & ia311242), the only thing in common with them is that they were both updated on May 9th. And the zip downloads have been fine earlier, just got reports of these corrupted ones recently.

Is there something that could be done?

Reply to this post
Reply [edit]

Poster: tracey pooh Date: Nov 21, 2009 2:29pm
Forum: faqs Subject: Re: Corrupt zip file with 'download whole directory'

oh and as to why this just seemed to have showed up...

just a few weeks ago we did a massive OS upgrade to all our machines. so some of the ways we read/write/process files has changed (one is a better and more efficient "zip on the fly")

thanks for the good catch, report, and your patience!
you are helping to make the archive a better place 8-)
-t

Reply to this post
Reply [edit]

Poster: Soft Phase netlabel Date: Nov 21, 2009 10:19pm
Forum: faqs Subject: Re: Corrupt zip file with 'download whole directory'

Ok, by partial upload files you probably mean those .pureftpd* files, that seem to be always left after my uploads, no matter what. They are not visible on the ftp directory, so one can't get rid of them by themselves.. They've been 0 bytes in size thou, so they haven't been a problem (until now, that is! :)

But the items being okay now is great, thank you for the help!

Reply to this post
Reply [edit]

Poster: tracey pooh Date: Nov 21, 2009 2:26pm
Forum: faqs Subject: Re: Corrupt zip file with 'download whole directory'

interesting.
seems that at least the sfp01flac
item was not working due to two "FTP turd/partial upload files"
which made our "zip on the fly" code make a bad zip.

i updated the code to omit such files so now both items are working.

as to why there are two separate/distinct items names (which will always end up in different directories if not servers) that's something you'd have to ask the uploader(s) about that!

--tracey